Problems to receive DHCP address

Frequently Asked Questions
Locked
jono
Posts: 85
Joined: 18 Apr 2008, 10:46
Location: Clavister HQ - Örnsköldsvik

Problems to receive DHCP address

Post by jono » 21 Apr 2008, 12:57

This FAQ applies to:
  • Clavister Security Gateway 8.x and up
Symptom:
The Security Gateway fails to receive an IP address from DHCP.

Solution:
The Security Gateway has some settings that could be altered in order to get the DHCP client to work.

The default settings in advanced settings->DHCP client is following:

Note: Path is Network->Interfaces and VPN->Ethernet->Advanced Settings in version 10.x and up.
  • DHCP_MinimumLeaseTime 60
    DHCP_ValidateBcast YES
    DHCP_AllowGlobalBcast NO
    DHCP_UseLinkLocalIP NO
    DHCP_DisableArpOnOffer NO
However. To have the Security Gateway accept uncommon IP offers you might have to make adjustments on the settings.
  • DHCP_MinimumLeaseTime 60
    DHCP_ValidateBcast NO
    DHCP_AllowGlobalBcast YES
    DHCP_UseLinkLocalIP NO
    DHCP_DisableArpOnOffer YES
Note: The swedish ISP Telia has some servers that causes problems with the default settings. Changing the settings to the following is known to work in those cases:
  • DHCP_MinimumLeaseTime 60
    DHCP_ValidateBcast NO
    DHCP_AllowGlobalBcast YES
    DHCP_UseLinkLocalIP NO
    DHCP_DisableArpOnOffer NO
In older Clavister Security Gateways there was an option to not set the default gateway before lease. This should be set to yes in the Telia case.

Note2: The swedish ISP COMHem has in some cities changed the minimum lease time to 30. Changing the settings to the following is known to work in those cases:
  • DHCP_MinimumLeaseTime 30
    DHCP_ValidateBcast NO
    DHCP_AllowGlobalBcast YES
    DHCP_UseLinkLocalIP NO
    DHCP_DisableArpOnOffer NO

mape
Posts: 41
Joined: 24 Oct 2016, 08:23

Re: Problems to receive DHCP address

Post by mape » 30 Nov 2016, 11:12

Note3: If having problems retrieving DHCP lease from the German provider Vodafone/Kabel Deutschland, a possible workaround would be to change the MAC Address of the connected interface. An example would be to use a MAC address in any of the following ranges:

x2:xx:xx:xx:xx:xx
x6:xx:xx:xx:xx:xx
xA:xx:xx:xx:xx:xx
xE:xx:xx:xx:xx:xx

or

52:54:00:xx:xx:xx

1. Create a new object: Go to Objects -> Address Book -> Add new Ethernet Address -> Set name and your new MAC Address.

2. Apply the earlier created MAC Address by going to: Network -> Interfaces and VPN -> Link Layer -> Ethernet -> <Interface> -> Hardware settings -> Manual MAC Address and select your new object.

Peter
Posts: 679
Joined: 10 Apr 2008, 14:14
Location: Clavister HQ - Örnsköldsvik

Re: Problems to receive DHCP address

Post by Peter » 09 Apr 2020, 16:20

Note4: We encountered a situation towards a Swedish ISP that was sending the DHCP replies from the DHCP server with TTL=1. By default cOS Core only allows a TTL of 3 or higher. In order to get this to work the TTLMin setting must be lowered from 3 to 1 or the "TTL on Low" setting be set to "ignore".

We recommend not disabling the "TTL on Low" setting as packets with TTL zero should be dropped.

These options can be found under System->Advanced Settings->IP Settings.

Locked