ILA/Logger service fails to start (1.30)

InControl Frequently Asked Questions
Post Reply
Peter
Posts: 665
Joined: 10 Apr 2008, 14:14
Location: Clavister HQ - Örnsköldsvik

ILA/Logger service fails to start (1.30)

Post by Peter » 06 Apr 2011, 09:06

This FAQ applies to
  • Clavister InControl version 1.20, 1.30
Question

After the installation of ILa is finished, there is an install log message that the service fails to start, manual start of the ILA service does not work either.

Answer

This problem is similar to the "Slow installations on machines without Internet access" mentioned in the following FAQ.

The problem is that Windows tries to verify the program certificates when the service starts, and without internet access the timeout is very long. So Windows will abort the service start as it believe the program does not respond. Bit of a catch 22 problem.

Workaround:

A secondary workaround to this issue (other than the one mentioned in the previously mentioned FAQ) is to manually create an ILA configuration file that contains information that it should not attempt to verify the certificates.

Go to your ILA installation directory, create a file called "ILA.exe.config" with e.g. notepad. Then add the following data to the configuration file:

Code: Select all

<?xml version="1.0" ?>
<!-- <configuration xmlns:xs="DotNetConfig.xsd" xmlns:vs="http://schemas.microsoft.com/.NetConfiguration/v2.0" > -->
<configuration>
<runtime>
<generatePublisherEvidence enabled="false"/>
</runtime>
</configuration> 
Now it should be no problem to start the ILA logging service.

Peter
Posts: 665
Joined: 10 Apr 2008, 14:14
Location: Clavister HQ - Örnsköldsvik

Re: ILA service fails to start

Post by Peter » 30 Apr 2012, 12:47

Update 2012-04-30:

Since the introduction of version 1.30.00 of InControl, the logger is now a separate program and process. A similar problem can occur on the new LogReceiver that the service fails to start.

Simply copy the "ILA.exe.config" when it has been modified as described above and name the copy "LogReceiver.exe.config". It should be placed in the directory where the Log Receiver is installed (usually in the same directory as the ILA).

Post Reply