Low Throughput VPN, HTTP, etc (SG3200 and others)

FAQ's for older versions of CorePlus/cOS Core
Post Reply
Tomas
Posts: 34
Joined: 15 Sep 2008, 15:57
Location: Clavister HQ - Örnsköldsvik

Low Throughput VPN, HTTP, etc (SG3200 and others)

Post by Tomas » 18 May 2011, 07:04

This FAQ applies to:
  • Clavister CorePlus™ 8.x and 9.x.
  • Clavister SG3200, but also other models.
Question:

Our VPN throughput is only a fraction of what I expect, e.g. on a 20 Mbps internet link, I only get 2-5 Mbps.
Our HTTP/FTP/... throughput is only a fraction of what I expect, e.g. on a 100 Mbps internet link, I only get 2-10 Mbps.

Answer:

1. Most likely this is caused by a too low High buffers (Highbuffers) setting. By default it is automatically calculated, but the total number of buffers is still too low for smooth operation.
Check in the CLI with the "stats" command.
Highbuffers on SG50 is by default 1779, which can be increased to around 2500 as maximum. Very few problems have been reported on this model, even with the default settings.
Highbuffers on SG3200 is by default around 6500 (depending on license etc) but it is WAY too few buffers for this model (and a few other X86 based ones).

Verify that you have available RAM (80 MB free or more) with the "mem" command, then do the following:

In System > Advanced Settings > Misc. Settings > Highbuffers: Uncheck the dynamic setting and enter 30 000 in the High Buffers field.
Perform a complete restart of the system.
Verify the new value with the "stats" command.
Double check RAM availability with the "mem" command.


2. You might have packet loss issues. This is handled in another FAQ, but in short, use PCAP to search for retransmissions and similar problems and eliminate them.

The throughput should now be back to normal.

Post Reply