Page 1 of 1

Known issue when setting up HA clusters in CorePlus 9.x

Posted: 07 Jul 2011, 10:22
by Tomas
This FAQ applies to
  • Clavister Security Gateway running CorePlus 9.15.06 and CorePlus 9.20.01-9.20.03.
    New setup of HA clusters using the backup & restore functionality.
    Identical hardware for both Master and Slave unit.
Question
a. Can I setup an HA master in CorePlus 9.x and take a backup of the configuration and restore it to the slave device?
b. I get the following error output, what is the cause?

Device:/> show -errors
Type Object
-------- ------
Ethernet if1
Ethernet if2
Ethernet if3
Ethernet if5
Ethernet if6
Ethernet sync

c. What causes this error?

Device:/> show Interface Ethernet if1
<cut>
EthernetDevice: 0:if1 1:<empty> Error:A reference to an object is required.
<cut>

Answer

In the above mentioned versions, a work-around must be followed, or the slave device will not operate properly, as the EthernetDevice is not properly setup.

The work around

(a)
1. Setup the HA master.
2. Open the CLI and for each interface (X) set the EthernetDevice:1 to the matching interface
Device:> set Interface Ethernet ifX EthernetDevice:1=ifX
3. Activate and Commit.
4. Verify all interfaces with the "show interface Ethernet ifX" CLI command that both EthernetDevices (0 and 1) are set to an interface. It should look something like this:
EthernetDevice: 0:ifX 1:ifX
5. Now the backup of the configuration can be created and restored on the Slave device. Before applying the configuration, change the node type to slave.
6. Finished.


(b) & (c)
Follow steps 2, 3, 4 and 6.